Lots of licensed and some free of cost script-driven applications have encrypted program code, that isn't human readable. The concept behind this is to avoid the reverse engineering and the unauthorized usage of such applications. One of the most popular file encryption software tools used for this purpose is known as Zend Guard and it's commonly used because it can be used to modify any type of PHP 4, PHP 5, PHP 7 and PHP 8 code. The only way for the protected files to work the right way on a web server afterwards is if another instrument called Zend Optimizer is there. In the event that you would like to work with any kind of paid web software that requires Zend Optimizer, you should ensure that it is set up on the server where you'll host your website. Also, sites that require the tool usually perform better because their code is already precompiled and optimized, meaning that it's executed quicker.

Zend Optimizer in Shared Web Hosting

Zend Optimizer is present on our tailor-made cloud platform and you are able to use it whatever the shared web hosting package that you select. It can be activated from the Hepsia Control Panel that comes with all the accounts and it will take you just a couple of clicks to do that. Since we support numerous releases of PHP (4, 5.2, 5.3, 5.4, 5.5, 5.6, 7.0, 7.1, 7.2, 7.3, 7.4, 8.0, 8.1, 8.2), you will have to activate Zend Optimizer each time you change the version to one you haven't used yet. This is really easy though - the php.ini file where you can enable and deactivate various PHP extensions can be managed with a point-and-click tool, and you will not need any kind of coding skills or previous practical experience. Our website hosting services will allow you to run any script-driven application which needs Zend Optimizer with no difficulties, yet in case you are unsure what to do, you'll be able to contact our 24/7 tech support crew and they will activate the instrument for you.

Zend Optimizer in Semi-dedicated Servers

Zend Optimizer is present on all the servers that comprise our cluster website hosting platform, which means that you'll be able to use it for all your script-driven apps with any of our semi-dedicated server packages. It'll be available all of the time even when you switch the PHP version for your account because our feature-rich platform will allow you to choose from PHP 4, 5.2, 5.3, 5.4, 5.5, 5.6, 7.0, 7.1, 7.2, 7.3, 7.4, 8.0, 8.1, 8.2. Both changing your version and activating Zend Optimizer for the new one takes a few clicks in the PHP Configuration area of the Hepsia hosting Control Panel that is used to take care of the semi-dedicated accounts. What is more, you can even employ a different version of PHP and activate or deactivate Zend for each individual website that you host from your account. You can do this by using a php.ini file in a domain folder with a couple of lines of program code inside it. If you don't have previous experience and you are not sure how to do that, our 24/7 support will assist.