PHP is among the most widely used reflective programming languages. It’s extremely popular since it’s free software, which you can use to develop interactive sites such as social networking websites, shopping portals or e-teaching portals rather than static HTML sites. A PHP module should be installed on the web server where a PHP site is hosted so that its code can be ‘translated’. As there are no license fees for this kind of module and the language itself provides incalculable options for the web-based applications that you develop, there are hundreds of millions of PHP-driven sites. On top of that, there’re numerous PHP-based scripts, which you can use for your websites without the need to have any programming knowledge. As there’re a few versions of PHP, you ought to ensure that the exact same version that you used whilst setting up your site is available on the server too.

PHP 4, PHP 5, PHP 7 and PHP 8 Support in Shared Web Hosting

We have reached a decision not to prevent our current and prospective clients from picking the PHP version that will be used by their websites, which suggests that in case you get a shared web hosting plan from us, you’ll be able to choose between versions 4, 5 and 7, not only for the account itself, but also for each individual domain hosted by you. This can be accomplished with just one mouse click from our custom-built Hepsia hosting Control Panel via which all web hosting accounts are managed, so you won’t have to possess any technical or programming skills. You’ll be able to manage sites built with both old and new PHP-based scripts without any hassles, so if you wish to abandon your current web hosting services provider and switch over to us, you can be certain that all the websites that you’ve built through the years will continue to run perfectly.

PHP 4, PHP 5, PHP 7 and PHP 8 Support in Semi-dedicated Servers

If you’ve got a site built with an older PHP version and you’ve put time and energy toward setting it up, fixing security breaches and publishing web content, you’ll need a web hosting service that can support it, since the great majority of hosting vendors nowadays offer only the most recently introduced version of PHP and drop the previous ones. We, however, have decided to allow you to choose the version that your very own sites need. Our Linux semi-dedicated hosting plans support PHP 4, PHP 5, PHP 7 and PHP 8, which suggests that you’ll be able to run both older and newer scripts without forfeiting any custom modifications or misspending time and efforts attempting to make your websites compatible with the hosting platform. You can change the current version through the Hepsia hosting Control Panel and such an update will apply to the whole semi-dedicated server account, but you will also be able to choose a different version of PHP for each single site that you host in your account using an .htaccess config file.